Jump to content

Custom Search






Welcome to the Ford Fiesta Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Fiesta Forum.  Like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup.
 
Be apart of the Ford Fiesta Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos, more. . .
Click here to create an account now
 
Guest Message by DevFuse

Photo
- - - - -

front LED problems

front led failure

  • Please log in to reply
No replies to this topic

#1 Fiesta 2013

Fiesta 2013

    New Fiesta Member

  • Fiesta Forum Member
  • Pip
  • 1 posts
  • Region:European Union
  • Location:Netherlands
  • Current Vehicle:Fiesta 2013

Posted 06 September 2017 - 07:45 AM

I've got a 2013 Fiesta with a very weird problem.

 

The LED strip in the front headlights is normally always on, except when the direction indicator is on. When de indicator is turned off, the LED strip is turned on again automatically.

 

The problem that i've got on my Fiesta is that the right LED strip stays turned OFF after using my right indicator, but only after i've had a bit of a drive. I've been to the Ford garage twice but they couldn't find any problem. Personally i think it's a software problem, since the LEDstrip works again after i restart the car. Now they offer to replace the whole headlight unit fot €650 but i think that won't solve the issue.

 

Does this issue sounds familiar to someone here?

 

Kind regards

 

 








Custom Search





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE (TOS) ·