Jump to content

Custom Search






Welcome to the Ford Fiesta Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Fiesta Forum.  Like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup.
 
Be apart of the Ford Fiesta Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos, more. . .
Click here to create an account now
 
Guest Message by DevFuse

Photo
- - - - -

High beam, low beam, wrong way round


  • Please log in to reply
No replies to this topic

#1 Samred123

Samred123

    New Fiesta Member

  • Fiesta Forum Member
  • Pip
  • 1 posts
  • Region:European Union
  • Location:England
  • Current Vehicle:Fiesta zetec 1.4 2004

Posted 12 May 2016 - 11:55 AM

Hi everyone, so my 2004 1.4 fiesta just failed it's MOT and here's the problem.
When I'm on low beam, the blue light in the dash board lights up to tell me in using high beam.
And when I'm on high beam it goes out as if I'm not using high beams.
Basically it's the wrong way around.
I already knew it was the wrong way around so I haven't been blinding people, I just have no idea how to fix it.
Any suggestions would be appreciated. Thanks






Custom Search





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE (TOS) ·