Jump to content

Custom Search






Welcome to the Ford Fiesta Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Fiesta Forum.  Like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup.
 
Be apart of the Ford Fiesta Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos, more. . .
Click here to create an account now
 
Guest Message by DevFuse

Photo
- - - - -

all around transmission problems


  • Please log in to reply
22 replies to this topic

#21 Cynthia Woolaver-Petrillo

Cynthia Woolaver-Petrillo

    New Fiesta Member

  • Fiesta Facebook Member
  • Pip
  • 1 posts

Posted 15 November 2014 - 10:57 PM

Got a 2011 fiesta hatchback last year, after my 14 year old Saturn died. Nothing but problems, same run around from dealership, no help, I Hate This Car! I Hate to Drive This Car! If I could I would Trade it in in a heartbeat! My husband bought it for me, he says he will lose to much money if he trades it in. Please do not buy any fiesta new or used! Waste of time and money! Has less than 25,000 miles on it, what do I have to look forward to later on,? More grief, If this runs according to ford standards! They need to raise their standards! I will never own another ford vehicle!

#22 Darryl

Darryl

    New Fiesta Member

  • Fiesta Forum Member
  • Pip
  • 8 posts
  • Region:U.S. Southern Atlantic
  • Location:Georgia
  • Current Vehicle:2012 Fiesta

Posted 25 June 2017 - 10:54 PM

I'm working with these guys... http://www.fordtrans...ionproblems.com

#23 albbbberto.66

albbbberto.66

    New Fiesta Member

  • Fiesta Forum Member
  • Pip
  • 1 posts
  • Region:U.S. Pacific Coast
  • Location:CA
  • Current Vehicle:2011 Ford Fiesta SE

Posted 10 July 2017 - 01:21 PM

So I just got a used 2011 Ford Fiesta with 100,000 miles and when I start to accelerate it like hesitant and jerks, but there is not problem when it. Doesn't jerk at all when it's changing gears, just from stopping point to accelerating. help pls






Custom Search





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE (TOS) ·